Only single LED lights on blinkygrid


#1

When I turn on my blinkygrid, only a single led comes on, and not one I would expect. I’ve tried programming, but holding the button while turning on power still results in just that one led. This is only my 3rd soldering project, so there is a significant chance that I’ve done something wrong there. I’ve uploaded photos of the front and back to imgur: http://imgur.com/a/v0EZI?gallery


#2

Hello bettse, sorry that your kit isn’t working correctly. I’m sure we’ll be able to figure it out.

There are eight signals going from eight pins on the chip to all 56 LEDs. The LED that is lighting up for you is labeled D27, and is connected to signals LED2 and LED3. These correspond to pins 8 and 7, respectively, of the chip.

Since these two pins are the bottom two pins of the chip, and the top two pins of the chip are power and ground, I’d guess that your chip was installed rotated 180 degrees? Ooh, in the first photo you posted I can see the little dimple (indicating pin 1) is at the bottom of the chip, when it should be at the top of the chip! Looks like the chip is backwards, that’s an easy thing to fix. Just ensure the power is turned off, pry out the chip with a small screwdriver or pliers (try not to bend any pins) and install it the other way:

Thanks a bunch for posting photos of your board right away, that makes it much easier to troubleshoot!


#3

Thank you! I had thought that I was supposed to match the notch in the chip with that of the socket, now it works and is showing me the preprogramming messages. On to programming!


#4

Excellent, glad it’s working! Ideally it should have the notch in the pcb match the notch in the socket match the notch/dot on the chip. The socket doesn’t matter but it’s usually a good idea to match it’s orientation with the chip and pcb.