Motor only Goes in Reverse


I am trying to run the nxt motors with the bricktronics shield but the motor will only move in one direction. Can anyone help out with helping me get it to move “Forward”? I am trying to run the single motor code from the bricktronics library using the Shield. I am also confused if I need to have jumper wires going from 1-2 or 3-4 or no jumpers needed at all.


Hello, thanks for the message.

Just to be clear, there are no jumpers involved for motors. Be certain that you are only plugging in motors to the two motor ports on the side of the Bricktronics Shield by the Arduino’s USB and power ports:

The only jumpers needed are for sensor ports 3 and 4, which support a variety of sensors.

What are you using for a power supply?

What kind of LEGO motors are you using? The standard NXT “servo” motor?

When you run the MotorSingleBricktronicsShield example code, what do you see for serial printouts? That example code will drive the motor forward slow, then forward fast, then reverse slow, then reverse fast, then repeat. Does the motor move at all after it prints out “Going in reverse.” ?

Thank you for the reply! I was pretty sure I didn’t need the jumpers for the motors but just wanted to check. I am useing the standard NXT servo motors and when I run the code everything prints in the serial monitor just fine. The motor only actually only moves in reverse (nothing happens when it says “going forward”).

When I rant the program motorbutton, if I change the speed to 200 the motor will go forward when I provide a little resistance towards the back. It moves forward EXTREMELY slow though when compared to it moving in reverse. Here is a video of it running

I am powering it with a 6AA battery pack but have also tried a 9V 1000mA wall charger as well. I have also tried 5 different motors and they all behave the same.

Thanks again!!

Thanks for all the details, that really helps! I’m glad you tried with different power supplies and different motors, so we know it’s not a problem with the power supply or motor.

Does it behave the same for motor port 1 and motor port 2?

I can’t think of anything else to try, so let’s get you a replacement kit. Please contact us using our web form and we’ll ship you a new kit (be sure to include your full mailing address, and phone number if you live outside the USA).

Sorry for the delay, I’ll fill it out tonight. Thanks for the support!

I have the very same problem. I have a couple of boards that I bought from LinkSprite but there is nothing that I can do to make it work properly. I tried moving reverse using negative angles, speed, etc.
Very bad… any help?

1 Like

LinkSprite boards are unlicensed knock-offs, we do not make a dime from those boards. I agree, they are very bad. They are also piggy-backing on our code, having put zero effort into software/firmware. They also are incorrect in the name “NXT/EV3” because EV3 sensors are not supported. Unfortunately, we can’t even begin to try to help you with this, because they do not publish their board schematic (as far as I can tell).

Ok… got screwed… do you ship your boards to Brazil?

We do ship to Brazil, but only via USPS Priority Mail and FedEx. We’ve had packages go missing before in Brazil, so we can’t support the less-expensive First Class shipping anymore. Thanks!

Ok, will purchase then.

Great! Thank you! We’re more than happy to provide support for legit W&L kits :smiley:

What sort of project are you working on? Which examples have you been testing?

Check this out…

I have the same problem on at least two of the three W&L motor driver boards I got recently. Drive in one direction. Nothing in the other. Same on both ports no matter which 5V Arduino pin I drive them from. PWM pin makes sense on both ports. EN pin makes sense. I swapped one motor driver board for the other thinking that was it and got nothing.