Motor example sketches not working

Hi, I brought a NXT/EV3 Brick Shield for Arduino from, no problem installing the libraries, tried out the example sketches for single and multiple motors, sketches complied without errors but on the single motor it only run one way (forward) and the multiple motors they are not running.

Please advise!


Never mind, I found the problem. I was using the wrong configuration. it’s all worked now!

Hi Jimmy, thanks for the message. I’m glad you were able to get it working. Just for future reference, the NXT/EV3 brick shield you mentioned is not a Wayne and Layne product. They’re using our Bricktronics software libraries, but we don’t have any input into their product.

Also, despite the name of their shield, the W&L software libraries do not yet support EV3 sensors. If you’re trying to do projects from the Make: LEGO and Arduino book, keep in mind that, as far as we can tell from the photos of their product, they did not include the TIP-120 transistors used for driving non-LEGO motors.

Adam Wolf