New OS X Builder


#21

Michael,

One more minor bug.

It looks like the directory ~/Library/Preferences/org.kicad-pcb is being created/owned by root, which doesn’t allow some configuration settings to be saved when running as a user. I changed ownership to my regular user and this seems to work correctly now. One example is on starting KiCad having it automatically open the last project you had opened, or being able to populate the “Recently Opened” menu option in the project manager. It seems a bunch of other preferences live here as well, so this might actually be more than a “minor” bug… :smile:

Otherwise I’ve been using PCBNew to edit an existing board (with appropriate saved files elsewhere!) and things seem to be working well. Eeschema still has bugs, but that’s ok, I can use my VM for that until we can get Eeschema working better!


#22

I updated launchpad with a new version. I also put a note on the kicad-users Yahoo forum.

Finally, I found the kicad-osx branch on launchpad. Bernhard has been patching KiCad for OS X so I am going to look at his patches and figure out how to apply. It appears he loosely follows upstream development.

Thanks for your notes!

Michael


#23

Hi,

I tried this on MBP2009 with 10.9.5:

bzr branch lp:~mnarigon/+junk/kicad-dev
cd kicad-dev/kicad-dev
./build.sh

And got:

Version: 0.2.1
Host/target is: OS X
Using up to 2 make jobs
Building Release build.
----------------------------------------------------------------------
Step 1: Check/create build directories...
----------------------------------------------------------------------
...done.
----------------------------------------------------------------------
Step 2: Check/configure the environment...
----------------------------------------------------------------------
Adding environment variables.
Please log out and log back in after this script completes to reset the environment.
...stopping.
elapsed time: 00:00:00 sec.

Tried to open new terminal window to reload env, also tried to logout/login, but it still tells me the same.

Andres

EDIT:
It does not work with zsh.
It worked if I changed to bash and then reopened new terminal window:

chsh -s /bin/bash

#24

andresv,
Thanks for the note! I have a fix in. I am trying to upload a new version tonight.

Michael


#25

Michael, thanks for your hard work on this!

I just ran the script (MBP2009, OS X 10.9.5) and I’m stuck on this error:

-- downloading...
    src='http://sourceforge.net/projects/libpng/files/libpng16/1.6.13/libpng-1.6.13.tar.gz'
    dst='/Users/chaz/dev/install/kicad-dev/kicad-dev/download/libpng-1.6.13.tar.gz'
    timeout='none'
CMake Error at /Users/chaz/dev/install/kicad-dev/kicad-dev/libraries-build/lib-png/stamp/download-lib-png.cmake:13 (file):
  file DOWNLOAD HASH mismatch

for file: [/Users/chaz/dev/install/kicad-dev/kicad-dev/download/libpng-1.6.13.tar.gz]
  expected hash: [1b446065d2c2e48f79ad98f7bde57286]
    actual hash: [d41d8cd98f00b204e9800998ecf8427e]
         status: [22;"HTTP response code said error"]

I tried replacing the hash in download-dev.sh, however this does not fix the issue. download-lib-png.cmake is rebuilt every time I run the script, using the “expected” hash. Any idea how to fix this?


#26

Hi zkarcher,
The libpng folks released a new version and moved the older one. The current version is 1.6.15. I uploaded a change. Thanks for letting me know. Michael


#27

Hi Michael,

Thanks for the builder. Your repository no longer exists, have you moved it somewhere else? Would be great if you could share the new location of the builder repository.

Sri Prasanna


#28

Hi Sri,
I took down the builder I developed since the KiCad developers are close to getting a builder for OS X running. The developers decided they didn’t want to use anything I had worked on. I will put the builder back up in twelve hours or so at the same link so you can grab a copy, however, it probably won’t work with the latest KiCad repository.

Michael


#29

Hi Sri,
I reloaded the last version. The download links still work. It uses BZR5304 of the KiCad repository. The repository is currently at BZR5341. I briefly looked at what it would take to update and there were more changes than I could fix in what time I could spare.


#30

Thanks Michael, appreciate it!


#31

Hi folks,

Just wanted to make sure everyone knew about the official OS X nightlies.

http://www.kicad-pcb.org/display/KICAD/Installing+KiCad#InstallingKiCad-MacOSX